SMS delivery issues in the US (+1). Please register or log in using an authenticator app.
Incident Report for Virtual Vaults
Resolved
This incident has been resolved.
Posted Sep 30, 2023 - 09:10 CEST
Identified
We are experiencing SMS delivery issues in the US. Please register or log in using an authenticator app.
Posted Sep 29, 2023 - 18:41 CEST
This incident affected: Virtual Vaults components (Authentication API).